Archivio Tag: Bugfix

WordPress 4.9.8, la scelta di Gutenberg

Gutenberg editor di WordPress

La nuova versione 4.9.8 di WordPress è arrivata, una release di mantenimento con diversi bugfix e aggiustamenti, compresa la soluzione ad un fastidioso problema di memoria della versione precedente.

Ma questo nuovo aggiornamento si porta in dote anche Gutenberg, il nuovo editor di WordPress, un nemmeno troppo timido accenno prima che diventi lo standard, con la prossima major release di WordPress 5.0.

Se vuoi vedere in azione Gutenberg, prima di cimentarti sul tuo sito, vai sul sito ufficiale di Gutenberg e guardati la demo in azione.

Dopo aver aggiornato WordPress alla versione 4.9.8 appare in bacheca il primo assaggio del nuovo editor, vedi immagine, con la possibilità di scegliere tra continuare con il vecchio e amichevole sistema o avventurarsi con il nuovo.

Personalmente consiglio di continuare con il metodo classico, e se proprio ci tieni a provare Gutenberg sul tuo sito fallo in un’installazione di stage, una copia del tuo sito ad uso e consumo proprio di questo genere di prove.

Il rischio di ritrovarsi con incompatibilità di temi e plugin con il nuovo editor è molto elevato, meglio non avventurarsi in situazioni che potrebbero compromettere il buon funzionamento del sito.

Qualunque sia la tua scelta, ad ogni modo, non dimenticare un provvidenziale backup completo prima di aggiornare!

C’è da aggiornare Yoast e WPML, tanti bug da sistemare.

Aggiornamenti Yoast e WPML di luglio 2018

In questa bollente mattinata di luglio ci sono da fare alcuni aggiornamenti importanti.

La suite WPML ha rilasciato le nuove versioni dei suoi principali plugin, e lo stesso per Yoast, che passa alla versione 7.9.

Quello che mi preme evidenziare è la lunga lista di bugfix che di tutti questi aggiornamenti, e inoltre la possibilità non troppo remota che, risolti questi problemi, se ne creino di nuovi.

Mai dare per scontato che l’aggiornamento di un plugin sia del tutto risolutivo o indolore, ed è per questo che un backup è fondamentale prima di procedere con qualsiasi aggiornamento.

WordPress 4.4.1, aggiornamento di mantenimento e sicurezza.

Aggiorna WordPress per la tua sicurezza

È disponibile nelle bacheche (per chi non ha disattivato gli aggiornamenti automatici, caldamente consigliato) la nuova versione di WordPress 4.4.1.

Si tratta di un aggiornamento di mantenimento, con una 50ina di bug risolti, ma come confermato anche dai principali siti di sicurezza risolve anche un problema di sicurezza di tipo XSS (Cross-Site Scripting).

Ho già aggiornato diverse installazioni, senza riscontrare problemi, ma in ogni caso è sempre prudente effettuare un backup completo prima di procedere.

WooCommerce 2.4.9, bugfix e sicurezza (subito aggiornato a 2.4.10)

Aggiornamento di sicurezza per WooCommerce

Aggiornamento: dopo poche ore è stato rilasciato WooCommerce 2.4.10, con una manciata di bugfix relativi alle funzioni di Geo IP. Evidente il precedente aggiornamento 2.4.9, segnalato ieri, non era del tutto a posto.

È stato appena rilasciato l’aggiornamento a WooCommerce 2.4.9. Si tratta di un aggiornamento con 18 bugfix, i più importanti riguardano il sistema Geo IP, ma risolve anche un problema di sicurezza ti tipo XSS (Cross Site Scripting), che riguarda il file price.php.

Devono fare attenzione, in particolare, gli utilizzatori di temi che sovrascrivono questo file: potrebbero continuare ad usare una versione vulnerabile, nonostante l’aggiornamento di WooCommerce.

Per chi volesse maggiori informazioni sui bug risolti, può sempre consultare il changelog.

Io di solito aspetto qualche ora prima di aggiornare, preferisco attendere i primi commenti in rete, ma come al solito la mamma di tutte le raccomandazioni per l’aggiornamento: un backup completo prima di cominciare, che non si sa mai!

Ciao, come posso aiutarti?
Powered by